
Photomatix Pro 2.5 User Manual

Introduction
Photomatix Pro processes multiple photographs of a high contrast scene into a single image 
with details in both highlights and shadows. 

This manual offers step-by-step instructions for using the main features of the Photomatix Pro 
software. The first section offers tips for taking photographs intended for High Dynamic Range 
(HDR) processing. The second section describes how to create HDR images and process them 
through tone mapping. The third section deals with the Exposure Blending functions, and the 
fourth section with the Batch Processing tool.

The following icons are used throughout the manual:
  Useful information and important note.
  Tips and recommendations.
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Section 1: Tips for Taking Successful Source Images

Section 1: Tips for taking photographs intended for HDR processing

Photographing a high contrast scene requires taking several exposures in order to capture 
information in both the brightest highlights and deepest shadows of the scene.

Photographs can be made with digital or film-based cameras.  The only requirement is that the 
exposure can be adjusted when taking pictures.  If you use a film-based camera, you will need 
to scan them into your computer before processing them.  Photomatix Pro can merge image 
files saved in JPEG, 8-bit or 16-bit TIFF, and PSD formats.  It can also create HDR images from 
the RAW files of several camera models.

There are two pieces of universal advice for creating differently exposed source images:
1) Make sure to take a sufficient number of exposures to properly cover the dynamic 
range of the scene, from the darkest shadows to the brightest highlights.
2) Use a sturdy tripod to keep your images perfectly aligned. Photomatix Pro 
incorporates Image Alignment functions, but using a tripod is still recommended.

Automatic Exposure Bracketing (AEB) for DSLR and compact digital cameras
 Shoot with available light whenever possible.  The flash may try to balance the exposure 

of all the images, when a range of exposures is the goal.
 Select a low ISO to minimize image noise.
 Select Continuous shooting mode on the camera’s drive setting to ensure that the 

bracketed photos will be captured with a single depression of the shutter button.  Consult 
your camera manual for model-specific instructions on using this setting.

 If possible, use the camera’s self-timer setting, or a cable release to minimize camera 
shake.

 Set your camera to Aperture priority (A setting) so that only the shutter speed varies 
between the exposures.  

 Set the camera to Auto Exposure Bracketing (AEB), which takes several photographs of 
a scene in a row:  one at the proper exposure, one or more underexposed, and one or 
more overexposed.  

o Most cameras allow to select the amount of over/under exposure in one-third or 
one-half increments.  The suggested exposure increment is +/- 2 for optimal 
exposure range.  If your camera does not offer +/- 2 exposure increment, select 
the maximum possible.  Consult the camera manual for model-specific 
instructions on choosing this setting.

DSLR LCD window showing AEB icon with +/-2 increments selected.
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Section 1: Tips for Taking Successful Source Images

o Select an appropriate number of auto-bracketed frames if your camera offers 
different options for the number of frames.  For instance, if your camera can 
auto-bracket at a maximum of +/-1 EV increments, then select 5 or more frames 
if your camera allows it.  Five frames spaced by +/-1 EV increment will give you 
the same dynamic range coverage as three frames spaced by +/-2 EV 
increments. 

 After capturing the bracketed images, check the histogram previews in playback 
mode to ensure that you have captured an adequate range of exposures. 

It is important to remember that the number of exposures needed depends on the dynamic 
range of the scene, in addition to the exposure increment.  For most outdoor scenes, three 
exposures taken at +/- 2 exposure increment will be sufficient, provided the scene does not 
include the sun. However, for the interior of a room with a bright view out of the window,  you will 
need at least five images taken with an exposure increment of +/- 2, or 9 images taken with an 
exposure increment of +/- 1. 

Manual Exposure Bracketing for DSLR cameras

In scenes with extreme differences between light and dark details, manual exposure bracketing 
over a greater exposure value range may provide better source images than Auto Exposure 
Bracketing, and it is the only option if your camera does not automatic bracketing over a wide 
enough range to cover your scene.  The following suggestions will help you to take optimal 
pictures using manual exposure bracketing. 

 Choose a low ISO to minimize noise and make the highest quality source images.
 Keep a constant aperture and ISO. Control image exposure by changing the shutter 

speed in full-stop increments. When taking pictures use either the A or M setting 
which both allow you to fix the aperture.

 Shoot a series of images starting with your brightest image elements (highlights) 
being slightly underexposed (see figure 2.1 below) to the darkest image elements 
(shadows) being slightly overexposed (see figure 2.2 below). You may or may not 
want or need to use every exposure in the series for HDR processing, but it is easier 
to delete a picture at processing time than to return to a location to take additional 
images. Experiment with different combinations of the bracketed source images in 
Photomatix Pro to achieve your desired effect.

 Check your DSLR's Histogram preview in playback mode to ensure that you have 
captured the entire tonal range of the image. You should have at least one picture 
without a large peak at the left side of the histogram and one picture without a large 
peak at the right side of the image.

 Self-timer mode, a cable release, and mirror lock-up options, if available, will help 
minimize any camera shake, especially for exposures slower than 1/15 second.
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Manual Exposure Bracketing with Compact Digital Cameras
Consult your camera’s user manual to determine if manual exposure is possible.  If this is 
possible, you can follow the steps for Manual Exposure Bracketing with a DSLR.

If your compact camera does not have  an AEB setting or allow you to set the exposure 
manually, you can use the exposure compensation setting to manually bracket. The series 
below shows the same scene captured at -2, 0 and +2.

LCD display

Film photo techniques for creating HDR source images
 Follow the advice for shooting with a digital camera, keeping in mind that you will not 

have the option of previewing the live histogram to determine your exposure range. 
 Scan your film or slides, not prints. Photo labs will attempt to make the best print from 

each of your source images, and you will not achieve good results scanning these in for 
HDR generation.
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Figure 2.1 Histogram depicts the brightest 
elements (highlights) slightly underexposed.

Figure 2.2 Histogram depicts the darkest 
image elements (shadows) slightly 
overexposed.
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 Turn off your scanner's auto-exposure options, so that you are manually controlling the 
exposure.

 Make sure to select the Align images option in Photomatix Pro when combining your 
images.
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Section 2: HDR Generation and Tone Mapping

Creating images that display the High Dynamic Range captured by photographs taken under 
different exposure settings is a two-step process: 

 The first step is to merge your differently exposed photographs into a single 32-bit 
HDR image. Because of its high dynamic range, a true 32-bit HDR image will not 
display properly on conventional monitors. 

 In the second step, this 32-bit HDR image is then processed, or ‘developed,’ via the 
Tone Mapping tool. This tool will 'reveal' the dynamic range captured in the HDR 
image and produce an image which can be properly displayed on conventional 
monitors and printed.

 The order of files in a bracketing sequence is not important. Photomatix Pro will 
systematically sort the image files based on exposure information retrieved from the 
EXIF data, or their relative brightness levels when the exposure information is not 
available.

Step 1: HDR Generation

Step 1A: Use the HDR>Generate HDR menu. The “Generate HDR – Specifying source images” 
window will display.

 If your source images are large TIFF files, use instead Batch Processing to generate 
the HDR image. Batch Processing includes an option, called “strip-by-strip processing”, 
that lets you  create HDR images from large source images in TIFF format without 
exceeding the available memory (RAM). 

Step 1B: Click Browse. The “Select differently exposed images” window will display to allow you 
to select the source images to be combined.
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Step 1C: Highlight the images taken under different exposures that you wish to use for HDR 
Generation. Then click OK. The selected image files will be listed on the “Generate HDR- 
Specifying source images”.

  

 Photomatix Pro can generate an HDR image from 8-bit, 16-bit and RAW source files. 
Supported file types include JPEG, TIFF, and RAW files from Canon, Nikon, Fuji, 
Olympus, Kodak, Minolta, Sony, Pentax, Panasonic and Leaf, as well as DNG files.
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Step 1D: Click OK to proceed further. 

 If the exposure information can not be found in the meta data, or if two or more 
source images share the same exposure information, Photomatix will show a window 
where you can input the relative Exposure Values for each one of your images. This 
window will also show if two or more source images have the same exposure setting.

The “Generate HDR- Options for merging source images to HDR” window will appear.

The above window is for the case when the source images are JPEG, TIFF or PSD files. When 
they are RAW files, the window will display slightly differently (see screenshot on the next page).

Step 1E: Check the desired options on the “Generate HDR - Options” window.

The “Align source images” option is checked by default. This option corrects for misalignment 
problems if the camera moved slightly between the bracketed frames, which may happen even 
when shooting with the aid of a tripod.  

If the scene has moving objects and you find the resulting 'ghosts' are not desirable, then check 
“Attempt to reduce ghosting artifacts” with the option “Moving objects/people” selected. If there 
are elements in the scene that follow a rhythmic pattern (flowing water for instance) oscillating 
between shadows and highlights, then select the option “Ripples” instead. In both cases, first try 
leaving the Detection option set to Normal. If you find that the resulting HDR image still shows 
too much ghosting, then try again with the option set to High.  

Only check the “Attempt to reduce ghosting artifacts” option if it is needed.  Checking it in other 
cases will lower the quality of the resulting HDR image. 
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When the source images are JPEG, TIFF or PSD files:
The recommended option “Take tone curve of color profile” is selected by default and is 
usually the best option when the images files come from a DSLR camera or have been 
converted from RAW files. This option loads the Tone Reproduction Curve data from the ICC 
color profile associated with the source images in order to determine the non-linear function 
applied to the raw sensors data. If no profile is available, it uses the tone reproduction curve of 
the Adobe RGB color profile.

When the images are scanned films or taken with a compact camera, it may be worthwhile 
checking the option “Attempt to reverse-engineer tone curve applied”. 

If your source images are 16-bit TIFF files that have been converted from RAW files with a 
special option in the RAW converter to leave the image in linear space, then check the option 
“No tone curve applied – pixel values are linear”. Only check this option, though, if you are 
100% sure that the tonal values of the image are linear relative to the values of light captured. 
Please note that the terminology linear may be used with a different meaning depending on the 
RAW converter (in Adobe Camera RAW for instance, linear is relative to the Adobe RGB color 
space and not to the values of light).

When the source images are RAW files:
The “Generate HDR - Options” window will display with additional options: 

It is important to note that the selected color space is used for its color primaries only, and not 
for its tone reproduction curve. Since the HDR image values are in linear space, they do not 
have a tone curve. The tone curve of the profile associated with the image will only be applied 
during the tone mapping step, and not to the HDR image itself.

Step 1F: Click OK to create the 32-bit HDR image.

A progress bar will display in the “Generate HDR –Options” window.  Once the HDR is 
generated, the HDR image and the HDR Viewer window will display on-screen.
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By default, Photomatix will use the "As Shot" 
White Balance (read from the EXIF metadata) 
when converting the RAW data to HDR. You 
can adjust the White Balance by selecting a 
pre-defined white balance from the drop-down 
menu or specify the color temperature in 
Kelvin. A preview lets you see the effect of the 
change on the source image. 

The RAW data is in a color space specific to 
the camera. Photomatix will convert the data 
into a standardized color space, by default 
Adobe RGB, but you can select sRGB or 
ProPhoto RGB instead.   



Section 2: HDR Generation and Tone Mapping

  Saving the 32-bit HDR image at this point will allow you to apply different Tone 
Mapping settings to the HDR source image without repeatedly following the “Generate 
HDR” procedure. However, note that the color profile information of the source images 
will not be preserved once the HDR image has been saved as Radiance or OpenEXR 
file. 

 Photomatix Pro allows you to create a 32-bit HDR image from a single RAW file. To do 
this, open one RAW file using File->Open, and Photomatix will convert it into a pseudo-
HDR image. However, it is important to note that an image created with a single RAW file 
can not really be considered High Dynamic Range. It is a rather a pseudo-HDR image. 
The important characteristic of this pseudo-HDR image is that it is unprocessed. Its 
dynamic range, however, is not much larger  than the range of an already converted file. 
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Step one of the two-step process is 
now complete.

Until Tone Mapping is applied, the 32-
bit image seen on screen can not 
display its full tonal range.

The small window called the “HDR 
viewer” shows a local section of the 
HDR image viewed at the appropriate 
exposure. 
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Step 2: Tone Mapping

The generated HDR image can not be represented properly on screen without further 
processing. An unprocessed HDR image is somewhat similar to a film negative or the RAW file 
of a digital camera. It needs further processing for display or printing. In Photomatix Pro, this 
processing is called Tone Mapping.

There are two tone mapping methods for processing the HDR image: Details Enhancer and 
Tone Compressor.

Tone Mapping with Details Enhancer
Photomatix Pro defaults to this option when the Tone Mapping window is opened. Details 
Enhancer utilizes a local operator to ‘develop’ the HDR image. This means that it takes into 
account the local brightness context -- a pixel of a given value in the HDR image will be mapped 
differently depending on whether it is located in a bright or dark area of the image.

Step 2A: Select the HDR>Tone Mapping menu to launch the Tone Mapping tool for the active 
open HDR image. If you have used the HDR>Generate menu to create a new HDR source 
image, it will be the active image. Otherwise, open a saved HDR image via the File>Open 
menu.

Step 2B: Use the slider controls to adjust the image. The preview on the right provides an 
approximation of what the image will look like once Details Enhancer is applied to the entire 
HDR source image. Note that, in the case of the Details Enhancer tone mapping method, the 
preview is not always an accurate representation of the final tone mapped image.
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Details Enhancer incorporates the following image adjustment sliders:

General adjustments:
 Strength: Controls the strength of contrast enhancements. A value of 100 gives the 

maximum increase in both local and global contrast enhancements.
 Color Saturation: Controls the saturation of the RGB color channels. The greater 

the saturation, the more intense the color. A value of zero produces a grayscale 
image. The value affects each color channel equally.

 Light Smoothing: Controls smoothing of light variations throughout the image. A 
higher value tends to reduce halos and give a more natural look to the resulting 
image. A lower value tends to increase sharpness.

 Luminosity: Controls the compression of the tonal range, which has the effect of 
adjusting the global luminosity level. Moving the slider to the right has the effect of 
boosting shadow details and brightening the image. Moving it to the left gives a more 
natural look to the resulting image.
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Tone adjustments:
 White Point - Black Point: Both sliders control how the minimum and maximum 

values of the tone mapped image are set. Moving the sliders to the right increases 
global contrast. Moving them to the left reduces clipping at the extremes. The White 
Point slider sets the value for the maximum of the tone mapped image (pure white or 
level 255). The Black Point slider sets the value for the minimum of the tone mapped 
image (pure black or level 0).

 Gamma: adjusts the mid-tone of the tone mapped image, brightening or darkening 
the image globally.

Color adjustments:
 Color Temperature:  Adjusts the color temperature of the tone mapped image 

relative to the temperature of the HDR source image. Moving the slider to the right 
gives a “warmer”, more yellow-orange colored look. Moving the slider to the left gives 
a “colder” more bluish look. A value of zero preserves the original color temperature 
of the HDR source image.

 Saturation Highlights:  Adjusts the color saturation of the highlights relative to the 
color saturation set with the Color Saturation slider. Values higher than zero increase 
the color saturation in the highlights, values lower than zero decrease it.

 Saturation Shadows:  Adjusts the color saturation of the shadows relative to the 
color saturation set with the Color Saturation slider. Values higher than zero increase 
the color saturation in the shadows, values lower than zero decrease it.

Micro adjustments:
 Microcontrast: Sets the level of accentuation of local details. 
 Micro-smoothing: Smoothes out local detail enhancements. This has the effect of 

reducing noise in the sky for instance, and tends to give a "cleaner" look to the 
resulting image.

 Important note: The 100% magnification view (displayed when clicking on the 
preview) may not properly show the effect of this setting when the area magnified 
is uniform. If you want, for instance, to see the effect of the micro-smoothing 
setting at 100% resolution on a uniform area such as the sky, you will have to 
select an area that contains an object in the scene in addition to the sky.

Shadows/Highlights adjustments:
 Highlights Smoothing:  Reduces the contrast enhancements in the highlights. The 

value of the slider sets how much of the highlights range is affected. This control is 
useful to prevents white highlights from turning grey, or uniform light blue skies 
becoming dark blue-grey. It is also useful in helping to reduce halos around objects 
placed against bright backgrounds.

 Shadows Smoothing:  Reduces the contrast enhancements in the shadows. The 
value of the slider sets how much of the shadows range is affected. 

 Shadows Clipping:  Controls the clipping of the shadows. The value of the slider 
sets how much of the shadows range is clipped. This control is useful to cut out 
noise in the dark area of a photo taken under low-light situation.
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Other setting:
 360º image: This option needs to be checked when the image processed is an 

equirectangular image intended to be viewed as a 360º panorama. This is because 
Details Enhancer takes into account local contrast and will assign different tonal 
values to the 360º seams of the panorama. This will produce a visible seam once the 
resulting image is rendered in a panorama viewer. Checking this option will correct 
for this.

 The 360º image option should only be checked for equirectangular 360º 
images. Checking it in other cases may produce less optimal results.

 Checking the 360º image option increases the amount of memory necessary 
to process the image by more than 50%. Processing times will also be 
increased.

Step 2C: Once you are satisfied with the results of the Details Enhancer adjustments, select a 
bit depth for the tone mapped image. A value of 8 means 8 bits per color channel and will allow 
you to save the image as JPEG or 8-bit TIFF file. A value of 16 means 16 bits per color channel 
and will provide a higher precision at the expense of a larger file size on disk. 

 If you plan to do additional processing in an image editing application, 16-bit is 
recommended. This is particularly recommended for print output.

Click Apply to create the tone mapped image.

 HDR>Undo Tone Mapping will undo the tone mapping settings applied to the original 
HDR image. The tone mapped image will revert to a 32-bit HDR image which can then be 
tone mapped again.
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Step 2D: Save the resultant file using the File>Save menu. You can rename the file and change 
the save location and file type, if desired. HDR>Save settings will save the applied tone 
mapping settings as an .xmp file so you can easily reproduce the same Tone Mapping process 
in the future.

  If you are tone mapping a large HDR image file (more than 40 MegaPixels for 
instance), do not open the HDR image in Photomatix Pro. Instead, click on HDR>Large 
File Processing and load the HDR image file from there. You will get the same tone 
mapping window and the preview as shown above. The only difference is that the 100% 
magnification view will not be enabled.

The Tone Mapping window offers additional settings, which are explained after tone 
mapping with Tone Compressor instructions on page 17.

In the example above, the HDR image was generated from these three source images.
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Tone Mapping with Tone Compressor 
Step 2A: Select the HDR>Tone Mapping menu to launch the Tone Mapping tool for the active 
open HDR image. If you have used the HDR>Generate menu to create a new HDR source 
image, it will be the active image. Otherwise, open a saved HDR image via the File>Open 
menu.

Step 2B: From the Tone Mapping window, select the Tone Compressor option button.

Step 2C: Use the slider controls to adjust the image. The preview on the right provides a view of 
what the image will look like once Tone Compressor is applied to the entire HDR source image. 
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Tone Compressor incorporates the following image adjustment sliders:
 Brightness: Influences the tone mapping process done on the HDR image in 

regards to overall image brightness.
 Tonal Range Compression: Controls how the tonal range of the 32-bit image is 

compressed into the 0-256 range of 8-bit monitors. The higher the value, the more 
both shadows and highlights will be shifted toward the center of the histogram. The 
Tone Compressor tone mapping method ignores local context.

 Contrast Adaptation: Sets how much the contrast is adapted to the intensity of the 
pixel values processed.

 White Point - Black Point: Both sliders control how the minimum and maximum 
values of the tone mapped image are set. Moving the sliders to the right increases 
global contrast. Moving them to the left reduces clipping at the extremes. The White 
Clip slider sets the value for the maximum (pure white or level 255). The Black Clip 
slider sets the value for the minimum (pure black or level 0).

 Color Temperature:  Adjusts the color temperature of the tone mapped image 
relative to the temperature of the HDR source image. Moving the slider to the right 
gives a “warmer”, more yellow-orange colored look. Moving the slider to the left gives 
a “colder” more bluish look. A value of zero preserves the original color temperature 
of the HDR source image.

 Color Saturation: Adjusts the color saturation of the tone mapped. The greater the 
saturation, the more intense the color.  The value affects each color channel equally.

Step 2D: Once you are satisfied with the results of the Tone Compressor adjustments, select a 
bit depth and click Apply to create the tone mapped image.

 HDR>Undo Tone Mapping will undo the tone mapping settings applied to the original 
HDR image. The tone mapped image will revert to a 32-bit HDR image which can then be 
tone mapped again.
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Step 2E: Save the resultant file using the File>Save menu. You can rename the file and change 
the save location and file type, if desired. HDR>Save settings will save the applied tone 
mapping settings as an .xmp file so you can easily reproduce the same Tone Mapping process 
in the future.

Additional Tone Mapping Settings
In addition to the image adjustment controls, the Tone Mapping window includes several other 
options and settings, which apply to both the Details Enhancer and Tone Compressor methods.
  

 Preview: Photomatix Pro offers three preview sizes: 512, 768 and 1024. A size of 
1024, for instance, means that the preview will be 1024 pixels wide for an image in 
landscape mode, and 1024 high for an image in portrait mode.  Select the radio 
button for desired size.

  Click the mouse on the preview to zoom in to 100% magnification. Click the 
mouse again to return to full image preview.

 Previous, Load, Default, Save, Undo Last Setting, Redo Last Setting: These six 
buttons allow you to use pre-set values for the Tone Mapping settings. Previous 
reverts to the settings that were used the last time you use the Tone Mapping tool. 
Default resets the settings to their default values. Save allows to save the settings to 
an XMP file that you can later re-use.  Load allows to load previously saved settings 
from an XMP file. Undo and Redo last settings allow for quick switching between the 
current and previous settings done on the Tone Mapping window.

 If you save the tone mapped image as a TIFF file, the tone mapping settings will be 
automatically embedded as XMP metadata in the TIFF file.  If you open the file in 
Photoshop, you can then view the tone mapping settings under File->Info->Advanced.
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 Bit Depth output image: 8-bit is the program’s default and will allow you to save the 
tone mapped image as JPEG or 8-bit TIFF. Select 16-bit for a tone mapped image 
with 16 bits per color channel that you can later save as 16-bit TIFF file. The default 
bit depth can be changed under the Tone  Mapping tab of Default Options which can 
be accessed from the View menu.

 When the bit depth of the output image is 8-bit, the default fil e format for saving 
the image will be set to JPEG. You can change it to TIFF instead using the Default 
Options dialog.
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Section 3: Exposure Blending

In addition to the two-step HDR processing described in the previous pages, Photomatix Pro 
also offers several single-step exposure blending methods that combine differently exposed 
images to show detail in both shadows and highlights.

 The Exposure blending methods work either with Batch Processing (section 4) or 
via the Combine menu with opened images. It is recommended that you use the Batch 
Processing functionality, particularly with large files.

These blending methods combine differently exposed photographs into a single image using the 
existing shadow and highlight detail from the source images to make a single final ‘blended’ 
image with an expanded tonal range. Here are some limitations to keep in mind.

 The blending methods do not process RAW files.
 The Highlights  & Shadows – Intensive method only supports 8-bit images.
 There is no limit to the number of source images you can blend, except when using  the 

method Highlights & Shadows – 2 images, which can only blend two photographs and is 
not available with Batch Processing.

The available blending methods are:
 Average 
 Highlights & Shadows – 2 images
 Highlights and Shadows – Auto
 Highlights & Shadows – Adjust
 Highlights & Shadows – Intensive

  The Exposure Blending methods are mostly automatic. It is recommended to execute 
them via the Batch Processing function, especially when blending 16-bit source images. 
Batch Processing has the additional advantage that you can blend the images with several 
methods in just one run and then select the most visually appealing image at the end.

The remainder of this section details the Exposure Blending method Highlights & Shadows – 
Adjust used via the Combine menu. For Exposure Blending via Batch Processing, please refer 
to section 4.
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Highlights & Shadows – Adjust
This method allows the user to control the blending point and radius of the blended image, and 
provides a preview window. 

Step 1: Open your source images into Photomatix Pro via the File>Open menu. (Use the Shift 
or Command key select and open multiple files at once.)

Step 2: Select Combine>Highlights & Shadows – Adjust. A preview window will display the 
exposure blending of your opened source images.

 The sliders to the left of and below the preview move the image section in the 
preview window. Click Zoom Out for a full image preview.

Step 3: Adjust the controls to achieve the desired effect. 

 Blending Point: Moving this slider to the right favors the overexposed images.  Moving 
it to the left favors the underexposed images.

 Radius: Moving this slider to the right increases sharpness and blending accuracy. 
Moving it to the left reduces halo artifacts.
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Section 3: Exposure Blending 

Step 4: Click OK.  Photomatix Pro will output an Exposure Blended file titled “Highlights & 
Shadows - Adjust”.

Highlight & Shadows – Adjust: Resulting blended image.

Step 5: File>Save will save your image. You can rename the file and change the save location 
and file type, if desired.
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Section 4: Batch Processing

Section 4: Batch Processing

The Batch Processing function of Photomatix Pro allows you to automate the processing of your 
images. Batch Processing may be used to:

 Process many exposure series to create HDR image files ready to be tone mapped 
individually. If you open another session of Photomatix Pro, you can start working on 
the first images while Batch Processing is still processing the remaining exposure 
series.

 Apply several different tone mapping or exposure blending methods to one set of 
source images.

 Apply the same tone mapping or exposure blending settings to several different sets 
of source images.

 Apply both of the above processes at once: applying many different tone mapping or 
exposure blending methods to several sets of source images

Step 1: Click on the Automate menu and select Batch Processing.
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Section 4: Batch Processing

 The files to be processed are selected alphabetically. Ensure that the files are named 
in a logical alphabetical manner if you have multiple file sets in one folder.

  Photomatix Pro can process subfolders with different numbers of source images in 
each folder, and can filter files by file type.

 It is important to note that when you are processing different sets of source images in 
a single folder, each set must contain the same number of source images.  If each set 
contains a different number of source images, you will need to place them into separate 
folders and select the All option for the number of files to process.

Step 2: Select the processes to be automated. At least one option described below (Options A-
G) must be selected to run the Batch Processor.

Option A: Generate HDR image

Check this option if you want to create a 32-bit HDR image. Click the Settings button to open an 
option window. 

If the source images are large TIFF files, check the option “Process strip by strip”. With this 
option, the HDR image file will be created in several passes, processing and loading only one 
strip of each image into memory at a time. One strip is composed of a limited number of rows 
set to not exceed around 512 MB of RAM once loaded. This option is particularly useful when 
processing large panoramas. 

If the source images are RAW files, White Balance and Color Primaries may be selected. 
Please refer to step 1E under the HDR Generation chapter of section 2 for details on those 
settings.

Option B: Process with Details Enhancer
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The first checkbox will allow input of EV 
spacing and will be used if no EXIF 
information is found in the source files. 

If there are moving objects in the source 
images and you find the resulting 'ghosts' are 
not desirable, check “Attempt to reduce 
ghosting artifacts” with the option “Moving 
objects/people” selected. If there are elements 
in the scene that follow a rhythmic pattern 
(flowing water for instance) oscillating 
between shadows and highlights, then select 
instead the option “Ripples”.

Only check the “Attempt to reduce ghosting 
artifacts” option if it is needed.  



Section 4: Batch Processing

Check this option if you want to automatically tone map the HDR image with the Details 
Enhancer method. Click the Settings button to open a window which allows you to adjust the 
Details Enhancer settings (described in Section 2). You may load settings which were saved in 
an XMP file in this window.

When the option Save is checked, the settings will be saved in an XMP file alongside the tone 
mapped images. This option is checked by default.

Option C: Process with Tone Compressor

Check  this  option  is  you  want  to  automatically  tone  map  the  HDR  image  with  the Tone 
Compressor method. Click the Settings button to open a window which allows you to adjust the 
Tone Compressor settings (described in Section 2). You may load settings which were saved in 
an XMP file in this window.

 Batch Processing lets you tone map your HDR images with Details Enhancer and 
Tone Compressor simultaneously.
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Section 4: Batch Processing

Option D: Average  

Check this option if you want to combine the source images using the average method.

Option E  :   H & S – Auto  

Check this option if you want to combine the source images with the exposure blending method 
Highlights & Shadows – Auto.

Option F: H & S – Adjust 
Check this option if you want to combine the source images with the exposure blending method 
Highlights and Shadows – Adjust. 

Option G: H & S – Intensive 

Check this option if you want to combine the source images with the exposure blending method 
Highlights & Shadows – Intensive Light/Enhanced
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Section 4: Batch Processing

 This exposure blending method can only process 8-bit source images. 

 Selecting this option will prompt a warning window when you click Run indicating that 
this exposure blending method will take a long time to process. 

Step 3: Select a number of source images to process at a time: 2-11 or All.

All should only be selected if you are using the Process Subfolders option, or if the folder 
processed contains only one set of bracketed exposures. When All is selected, Photomatix will 
attempt to process all images in each folder, so it is important that only one set of source 
images be in each subfolder. 

 It is possible to Batch Process multiple series of source images with varying numbers 
of source images, if each series is in its own subfolder, and All is selected. 

 If all source images from multiple series are in a single folder, each series must have 
the same number of source images. Images are processed alphabetically, so each 
series should be assigned a logical naming method. For example: A_Castle1.jpg, 
A_Castle2.jpg, A_Castle3.jpg followed by B_Sunrise1.jpg, B_Sunrise2.jpg, 
B_Sunrise3.jpg.

 
Step 4: Check Align Images, if necessary, to correct for slight camera movement between 
source photographs.

When Align images is checked, the images will be cropped after alignment in order to remove 
invalid areas on the edge due to the correction for mis-alignment shifts. If you want to skip the 
cropping, then check the Don't crop option. This option may be useful if you are processing 
images intended to be stitched together to create a panorama.

Step 5: Choose a source folder. 

Select the source file folder from the list of folders in the source section.

If you want to batch process several folders, then check the Process Subfolders option.

 Use Process Subfolders if you have multiple series of source images which vary in 
the number of source images they contain. The Batch Processing can process series 
with varying numbers of source images if each series is in its own subfolder and All is 
selected.

Select a file type from the Filter by File Type dropdown, if necessary. Options are: All, TIFF, 
JPEG, PSD and RAW.

 This option is useful if a source folder contains RAW+JPEG from a camera, and you 
are processing only one file type.
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Section 4: Batch Processing

Step 6: If necessary select a Destination location. 

By default, Same as source is selected. With this option, the Batch Processing will save the 
resulting images in a subfolder within the source folder. The resulting folder will be prefixed by 
‘PhotomatixResult’. Checking Select allows you to select a specific (different) location on your 
computer. 

Select a file type for saving, JPEG or TIFF. If JPEG is selected, select a JPEG Quality, from 10-
100. If applicable, select an HDR file type for saving the HDR image file: Radiance RGBE or 
OpenEXR. If you want to save only the Tone Mapping results and not the 32-bit HDR image, 
check Remove generated HDR image after processing.

Click Naming Options to choose a naming strategy.
 

 Start with Set Number or Start with Filename of first image in the set are the main 
options. Start with Set number will yield long names such as: 
Set01Enhancer3from_IMG_3421.jpg. Checking Use shortened version will yield shorter 
names that do not reference the source files: Set01Enhancer.jpg, for example. Start with 
Filename of first image in the set yields file names that start with the first image in the 
set: IMG_3431_2_3Enhancer.jpg, for example. Suffix (optional) will append additional 
file name information to the end of the assigned file names.

Step 7: Click Run to start batch processing. 

The window below the Run button will show the status of each process in real time. 
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